Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Александр


     

Форум:

Список тем -> Как определить сотрудников, у которых есть остатки по зарплате

1. Сергей finansoft.ru     id 1         31.01.2014 15:06
// Выбираем остаток по регистру накопления
ЗапросРег=Новый Запрос("ВЫБРАТЬ
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток
|ИЗ
| РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Остатки(&Дата) КАК ВзаиморасчетыСРаботникамиОрганизацийОстатки
|ГДЕ
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.Физлицо = &Физлицо
| И ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток 0");
ЗапросРег.УстановитьПараметр("Дата",НачалоДня(С_Даты));
ЗапросРег.УстановитьПараметр("Физлицо",РЗ.Ссылка.Физлицо);
РЗРег=ЗапросРег.Выполнить().Выбрать();

// Сообщаем ФИО сотрудника, у которого остаток 0
Пока РЗРег.Следующий() Цикл
Сообщить(""+РЗ.Ссылка+" "+РЗРег.СуммаВзаиморасчетовОстаток);
КонецЦикла;
Ответить    Написать автору на email   Комментарии_0
2. Сергей finansoft.ru     id 1         31.01.2014 16:27
Более правильный и полный код:

// выбираем ФизическиеЛица
Запрос=Новый Запрос("ВЫБРАТЬ
| ФизическиеЛица.Ссылка КАК Ссылка
|ИЗ
| Справочник.ФизическиеЛица КАК ФизическиеЛица
|ГДЕ
| ФизическиеЛица.ЭтоГруппа = Ложь");
РЗ=Запрос.Выполнить().Выбрать();
Пока РЗ.Следующий() Цикл

ОбработкаПрерыванияПользователя();

//Сообщить(РЗ.Ссылка);
// Выбираем остаток по регистру накопления
ЗапросРег=Новый Запрос("ВЫБРАТЬ
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток
|ИЗ
| РегистрНакопления.ВзаиморасчетыСРаботникамиОрганизаций.Остатки(&Дата) КАК ВзаиморасчетыСРаботникамиОрганизацийОстатки
|ГДЕ
| ВзаиморасчетыСРаботникамиОрганизацийОстатки.Физлицо = &Физлицо
| И ВзаиморасчетыСРаботникамиОрганизацийОстатки.СуммаВзаиморасчетовОстаток 0");
ЗапросРег.УстановитьПараметр("Дата",НачалоДня(С_Даты));
ЗапросРег.УстановитьПараметр("Физлицо",РЗ.Ссылка);
РЗРег=ЗапросРег.Выполнить().Выбрать();
// Сообщаем ФИО сотрудника, у которого остаток 0
Пока РЗРег.Следующий() Цикл
Сообщить(""+РЗ.Ссылка+" "+РЗРег.СуммаВзаиморасчетовОстаток);
КонецЦикла;

КонецЦикла;
Ответить    Написать автору на email   Комментарии_0
Страница 1


*
 
Copyright © 2012-2017 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru