Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Сергей finansoft.ru


Содержание

Как заполнить значения свойств нового документа на основании существующего?


НовыйСчет = Документы.СчетНаОплатуПокупателю.СоздатьДокумент(); 
ЗаполнитьЗначенияСвойств(НовыйСчет, ДокументЗаказа, , "Дата");
// Заполнить табличную часть Товары.
Для Каждого СтрокаТоваровЗаказа Из ДокументЗаказа.Товары Цикл
ЗаполнитьЗначенияСвойств(НовыйСчет.Товары.Добавить(), СтрокаТоваровЗаказа);
КонецЦикла;
// Заполнить табличную часть ВозвратнаяТара
Для Каждого СтрокаТарыЗаказа Из ДокументЗаказа.ВозвратнаяТара Цикл
ЗаполнитьЗначенияСвойств(НовыйСчет.ВозвратнаяТара.Добавить(), СтрокаТарыЗаказа);
КонецЦикла;
// Заполнить табличную часть Услуги
Для Каждого СтрокаУслугЗаказа Из ДокументЗаказа.Услуги Цикл
ЗаполнитьЗначенияСвойств(НовыйСчет.Услуги.Добавить(), СтрокаУслугЗаказа);
КонецЦикла;
НовыйСчет.ЗаказПокупателя = ДокументЗаказа;
Форма = НовыйСчет.ПолучитьФорму();
Форма.Открыть();
Copyright © 2012-2018 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru