Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Содержание

Как изменить цвет фона ячейки табличного поля в зависимости от значения, выводимого в нее?


Процедура ТоварыПриПолученииДанных(Элемент, ОформленияСтрок) 
Для Каждого ОформлениеСтроки Из ОформленияСтрок Цикл
ЗначениеЯчейкиОстаток = ОформлениеСтроки.Ячейки.Остаток.Значение;
Если ЗначениеЯчейкиОстаток <> Неопределено Тогда
Если ЗначениеЯчейкиОстаток < 10 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Красный;
ИначеЕсли ЗначениеЯчейкиОстаток > 100 Тогда
ОформлениеСтроки.Ячейки.Остаток.ЦветФона = WebЦвета.Желтый;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Copyright © 2012-2018 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru