Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Содержание

Как реализовать перетаскивание между элементами управления?


Процедура НоменклатураНачалоПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка) 
// Получить значение, переданное системой.
Значение = ПараметрыПеретаскивания.Значение;
// В любом случае значением будет массив.
МассивЗначений = Новый Массив;
// Если перетаскивается группа, то в массив записываем входящие в нее элементы.
Если Значение.ЭтоГруппа Тогда
Выборка = Справочники.Номенклатура.Выбрать(Значение);
Пока Выборка.Следующий() Цикл
Если Не Выборка.ЭтоГруппа Тогда
МассивЗначений.Добавить(Выборка.Ссылка);
КонецЕсли;
КонецЦикла;
Иначе
МассивЗначений.Добавить(Значение);
КонецЕсли;
// Заполненный массив записываем в параметры.
ПараметрыПеретаскивания.Значение = МассивЗначений;
КонецПроцедуры
Процедура ТоварыПроверкаПеретаскивания(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
СтандартнаяОбработка = Ложь;
КонецПроцедуры
Процедура ТоварыПеретаскивание(Элемент, ПараметрыПеретаскивания, СтандартнаяОбработка, Строка, Колонка)
ПолученныйМассив = ПараметрыПеретаскивания.Значение;
Если ТипЗнч(ПолученныйМассив) = Тип("Массив") Тогда
Для Каждого Значение Из ПолученныйМассив Цикл
НоваяСтрока = ДокументОбъект.Товары.Добавить();
НоваяСтрока.Номенклатура = Значение;
НоваяСтрока.Количество = 1;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
Copyright © 2012-2018 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru