Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Содержание

Как в командной панели создать подменю с кнопками?


КнопкиКоманднойПанели = ЭлементыФормы.КоманднаяПанельФормы.Кнопки; 
// Проверить, нет ли уже на командной панели кнопки "Сформировать".
// Если есть - удалить.
Индекс = КнопкиКоманднойПанели.Индекс(КнопкиКоманднойПанели.Найти("Сформировать"));
Если Индекс = -1 Тогда
Индекс = 0;
Иначе
КнопкиКоманднойПанели.Удалить(Индекс);
КонецЕсли;
// Создать подменю "Сформировать".
ПодменюСформировать = КнопкиКоманднойПанели.Вставить(Индекс, "Сформировать", ТипКнопкиКоманднойПанели.Подменю, "Сформировать");
// Добавить картинку.
ПодменюСформировать.Картинка = БиблиотекаКартинок.Сформировать;
ПодменюСформировать.Отображение = ОтображениеКнопкиКоманднойПанели.НадписьКартинка;
// Опросить перечисление о возможных вариантах периодичности.
Запрос = Новый Запрос("ВЫБРАТЬ Ссылка ИЗ Перечисление.Периодичность");
Выборка = Запрос.Выполнить().Выбрать();
//Добавить кнопки к подменю.
Пока Выборка.Следующий() Цикл
Период = Выборка.Ссылка;
ПодменюСформировать.Кнопки.Добавить("кн" + Период, ТипКнопкиКоманднойПанели.Действие, "Сформировать за " + Период, Новый Действие("КнопкаСформироватьНажатие"));
КонецЦикла;
Процедура КнопкаСформироватьНажатие(Элемент)
НазваниеПериодичности = СтрЗаменить(Элемент.Имя, "кн", "");
КонецПроцедуры
Copyright © 2012-2018 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru