Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Сергей finansoft.ru


Содержание

Отчет формируется построителем отчета. Как убрать одну из колонок, поместив ее данные в расшифровку другой?


Процедура АлфавитныйПереченьКандидатовСРасшифровкой() 
ПостроительОтчета = Новый ПостроительОтчета;
ПостроительОтчета.Текст ="ВЫБРАТЬ
| РегистрацияСобеседованияКандидата.ФизЛицо КАК Кандидат,
| РегистрацияСобеседованияКандидата.РезультатСобеседования КАК Результат,
| РегистрацияСобеседованияКандидата.Ссылка
|ИЗ
| Документ.РегистрацияСобеседованияКандидата КАК РегистрацияСобеседованияКандидата
|УПОРЯДОЧИТЬ ПО
| РегистрацияСобеседованияКандидата.ФизЛицо.Наименование";
ПостроительОтчета.Выполнить();
Макет = ПостроительОтчета.Макет;
// Очистить области, связанные с ссылкой.
ТекущаяОбласть = Неопределено;
Пока Истина Цикл ТекущаяОбласть = Макет.НайтиТекст("Ссылка", ТекущаяОбласть, Макет.Область());
Если ТекущаяОбласть = Неопределено Тогда
Прервать;
Иначе
ТекущаяОбласть.Очистить(Истина, Истина, Истина);
КонецЕсли;
КонецЦикла;
// Заполнить параметр расшифровки для областей, где параметр = "Результат".
ТекущаяОбласть = Неопределено;
Пока Истина Цикл ТекущаяОбласть = Макет.НайтиТекст("Результат", ТекущаяОбласть, Макет.Область());
Если ТекущаяОбласть = Неопределено Тогда
Прервать;
Иначе
Если ТекущаяОбласть.Параметр = "Результат" Тогда
ТекущаяОбласть.ПараметрРасшифровки = "Ссылка";
КонецЕсли;
КонецЕсли;
КонецЦикла;
ПостроительОтчета.Макет = Макет;
ПостроительОтчета.Вывести();
КонецПроцедуры
Copyright © 2012-2018 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru