Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Содержание

Табличный документ формируется построителем отчета. Как для всех выводимых числовых показателей установить вывод без дробной части


// Получить макет построителя отчета. 
Макет = ПостроительОтчета.Макет;
// Сформатировать все области, где встречается слово "Стоимость".
ТекущаяОбласть = Неопределено;
Пока Истина Цикл
ТекущаяОбласть = Макет.НайтиТекст("Стоимость", ТекущаяОбласть, Макет.Область());
Если ТекущаяОбласть = Неопределено Тогда
Прервать;
Иначе
Если ТекущаяОбласть.Параметр <> "" Тогда
ТекущаяОбласть.Формат = "ЧДЦ=0";
КонецЕсли;
КонецЕсли;
КонецЦикла;
// Сформатировать все области, где встречается слово "Количество".
ТекущаяОбласть = Неопределено;
Пока Истина Цикл
ТекущаяОбласть = Макет.НайтиТекст("Количество", ТекущаяОбласть, Макет.Область());
Если ТекущаяОбласть = Неопределено Тогда
Прервать;
Иначе
Если ТекущаяОбласть.Параметр <> "" Тогда
ТекущаяОбласть.Формат = "ЧДЦ=0";
КонецЕсли;
КонецЕсли;
КонецЦикла;
// Назначить построителю измененный макет.
ПостроительОтчета.Макет = Макет;
// Вывести результат работы построителя отчета в табличный документ.
Copyright © 2012-2018 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru