Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Содержание

Как программно добавить пользователя в информационную базу?


НовыйПользователь = ПользователиИнформационнойБазы.СоздатьПользователя(); 
НовыйПользователь.Имя = "Имя";
НовыйПользователь.ПолноеИмя = "Фамилия Имя Отчество";
НовыйПользователь.АутентификацияСтандартная = Истина;
НовыйПользователь.ОсновнойИнтерфейс = Метаданные.Интерфейсы.Администратор;
НовыйПользователь.Пароль = "пароль";
НовыйПользователь.Роли.Добавить(Метаданные.Роли.Администратор);
НовыйПользователь.ПоказыватьВСпискеВыбора = Ложь;
НовыйПользователь.Язык = Метаданные.Языки.Русский;
НовыйПользователь.Записать();
ЗаписатьНовогоПользователя(НовыйПользователь);
Процедура ЗаписатьНовогоПользователя(НовыйПользователь) Экспорт
// Проверить наличие роли Администратор у нового пользователя.
РольАдминистратор = Метаданные.Роли.Администратор;
Если НовыйПользователь.Роли.Содержит(РольАдминистратор) Тогда
Сообщить("Добавление пользователя с административными правами запрещено.");
Иначе // у нового пользователя нет роли Администратор
// Проверить, что текущий пользователь обладает правами Менеджера
// или Администратора
Если РольДоступна(РольАдминистратор) ИЛИ РольДоступна(Метаданные.Роли.Менеджер) Тогда
// Выполнить запись нового пользователя.
НовыйПользователь.Записать();
Иначе
Сообщить("Недостаточно прав доступа для добавления пользователя.");
КонецЕсли;
КонецЕсли;
КонецПроцедуры
Copyright © 2012-2018 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru