Главная Регистрация Форум Поиск по форуму Продать разработку Программное обеспечение Опубликовать статью Статьи по программированию Общение Сообщества Фриланс Добавить проект Web-бухгалтерия Железо Книги

forum1C8.ru

Социальная сеть программистов
 


 Авторизация
Логин:

Пароль:



 Забыли пароль ?

 Регистрация
На сайте:
Содержание

Как выгрузить журнал регистрации в XML-формате?


ВыгрузитьЖурналРегистрации("C:\log.xml"); 
Пользователи = ПользователиИнформационнойБазы.ПолучитьПользователей();
Для Каждого Пользователь из Пользователи Цикл
НовыйЭлемент = СписокПользователей.Добавить();
НовыйЭлемент.Пометка = Истина;
НовыйЭлемент.Значение = Пользователь;
НовыйЭлемент.Представление = Пользователь.Имя;
КонецЦикла;
Массив = Новый Массив;
Для Каждого Пользователь Из СписокПользователей Цикл
Если Пользователь.Пометка Тогда
Массив.Добавить(Пользователь);
КонецЕсли;
КонецЦикла;
СтруктураФильтра = Новый Структура;
СтруктураФильтра.Вставить("Пользователь", Массив);
ВыгрузитьЖурналРегистрации("C:\log.xml", СтруктураФильтра, "Дата, Пользователь, ПредставлениеСобытия");
Copyright © 2012-2018 forum1C8.ru
http://www.forum1c8.ru
Сделать стартовой
Добавить в Избранное

Нравится

Программирование finansoft.ru